Skip to end of metadata
Go to start of metadata
Table of Contents

New CAS documentation site

Icon

CAS documentation has moved over to apereo.github.io/cas, starting with CAS version 4.x. The wiki will no longer be maintained. For the most recent version of the documentation, please refer to the aforementioned link.

Java 5 is required to build and deploy CAS 3.1. However, there appear to be some issues with various versions of Java on various platforms.

On the Windows PC, building CAS has been tested with the following:

  • JDK 1.5.0_8 and higher
  • JDK 1.6 and higher

On Linux Machines, building CAS has been tested with the following:

  • JDK 1.6 and higher

On a Macintosh, building CAS has been tested with the following:

  • JDK 1.5 (if tests are disabled, see note below)

On a Solaris machine, it hasn't been tested but mostly one will need the following:

  • JDK 1.6 or higher

There appears to be certain Sun-specific classes that may or may not appear in a particular JDK (i.e. its in JDK 1.5.0_08 for the Windows machine but not for the Linux machine).

If you encounter missing classes and do not want to change your Java version, you can run Maven 2 with the following flag: "-Dmaven.test.skip=true"

 

CAS 3.5

Please note that CAS 3.5 requires JDK 1.6 and higher.

On Windows 7 machine, building and deploying CAS 3.5 has been tested with:

  • JDK 1.7.05
  • JRE 1.7.05
  • Maven 3.0.4
On OS X (10.7.4) machine, building and deploying CAS 3.5 has been tested with:
  • JDK 1.6.0_33
  • JRE 1.6.0_33
  • Maven 3.0.4

CAS 4.x

Please be advised that the official end of life for JDK 1.6 has been set for November 2012: http://www.oracle.com/technetwork/java/eol-135779.html Due to this fact the minimum source level support for CAS 4+ will be JDK 1.6

 

  • No labels